Go Back   Ducati 1299 Forum > Ducati Panigale Forum > Ducati 1199

Ducati 1199 Ducati 1199 Forum - Ducati 1199 Panigale Superbike Motorcycle Forum


Thanks Tree7Thanks
Reply
 
LinkBack Thread Tools Display Modes
Old Sep 7th 2012, 01:15 PM   #1
Senior Member
 
Styler's Avatar
 
Joined: Apr 2012
From: Northern CA and NW Arkansas, USA

Posts: 844
Thanks: 302

I Ride: 2012 1199S, 2008 Speed Triple
Horn and Signal Issues

I was having intermitent horn and signal malfunctions. Occasionally, my right turn signals would not work (front and back, and on dash) and the horn would not work when this occured. A temporary fix for this was to turn off the bike and let the ECU reset; however, the issue would always come back.

I took the bike to the Dealer, who confirmed that the ECU in the dash (there are 5 ECUs on this bike, the dash contains a slave ECU) had failed and so they have replaced it under warranty.

I post this so that others will know what to do if this happens to you.
Thanks from JeffD
Styler is offline  
 
Old Sep 7th 2012, 02:39 PM   #2
Junior Member
 
Joined: Aug 2012
From: TEXAS

Posts: 25
Thanks: 0

I Ride: 1199 base
There's another thread on here I just read about this and one of the guys said it was the dash ecu. I have the same problem. Atleast it is covered under warranty!
I think the riders know more about this bike than Ducati does, sad.
DRAGAKNEE is offline  
Old Sep 8th 2012, 08:13 AM   #3
Member
 
Joined: Sep 2012
From: New York City

Posts: 31
Thanks: 4

I Ride: 2012 Ducati 1199s
Similar issue

Originally Posted by Styler View Post
I was having intermitent horn and signal malfunctions. Occasionally, my right turn signals would not work (front and back, and on dash) and the horn would not work when this occured. A temporary fix for this was to turn off the bike and let the ECU reset; however, the issue would always come back.

I took the bike to the Dealer, who confirmed that the ECU in the dash (there are 5 ECUs on this bike, the dash contains a slave ECU) had failed and so they have replaced it under warranty.

I post this so that others will know what to do if this happens to you.
My right signal goes out every so often, but i don't want to take it to them until i can show them at that moment that it's not working.
nomnom37 is offline  
Old Sep 8th 2012, 11:04 AM   #4
Member
 
Lotto's Avatar
 
Joined: Jul 2012
From: Ft Rucker, AL

Posts: 66
Thanks: 6

I Ride: 2012 Ducati 1199S, 2008 Kawasaki KLX-450R
right signal not working

I just got done riding and had my first real problem with the bike after 2 months. My right turn signal stopped working. Thanks for the posts. Now I can tell the dealer what the problem is when I bring it in.
Lotto is offline  
Old Sep 8th 2012, 11:37 AM   #5
Senior Member
 
Joined: May 2012
From: Austin Fucking Texas Bitches!!!

Posts: 178
Thanks: 16

Have them call Bull at Ducati Austin... he knows all about this problem from my experience... 512-236-8822
Thanks from JeffD
thomaskenyon is offline  
Old Sep 9th 2012, 11:30 AM   #6
Member
 
Joined: Mar 2012
From: central Florida

Posts: 41
Thanks: 6

I Ride: 1199 ABS, Monster S4
My Base/ABS has the same problem, and i'm waiting for a new dash to ship to my dealer. How long did yours take to arrive? i've been waiting almost two weeks so far.
omega10 is offline  
Old Sep 10th 2012, 07:13 AM   #7
Senior Member
 
Joined: May 2012
From: Austin Fucking Texas Bitches!!!

Posts: 178
Thanks: 16

Mine took a week..
thomaskenyon is offline  
Old Sep 10th 2012, 01:52 PM   #8
Senior Member
 
Styler's Avatar
 
Joined: Apr 2012
From: Northern CA and NW Arkansas, USA

Posts: 844
Thanks: 302

I Ride: 2012 1199S, 2008 Speed Triple
Originally Posted by omega10 View Post
My Base/ABS has the same problem, and i'm waiting for a new dash to ship to my dealer. How long did yours take to arrive? i've been waiting almost two weeks so far.
Within a week.
Styler is offline  
Old Sep 10th 2012, 05:46 PM   #9
Senior Member
 
Mitchlguzin's Avatar
 
Joined: Feb 2012
From: Illinois

Posts: 469
Thanks: 82

I Ride: Ducati Panigale 1199 S...
Originally Posted by Styler View Post
I was having intermitent horn and signal malfunctions. Occasionally, my right turn signals would not work (front and back, and on dash) and the horn would not work when this occured. A temporary fix for this was to turn off the bike and let the ECU reset; however, the issue would always come back.

I took the bike to the Dealer, who confirmed that the ECU in the dash (there are 5 ECUs on this bike, the dash contains a slave ECU) had failed and so they have replaced it under warranty.

I post this so that others will know what to do if this happens to you.
I've noticed a similar issue recently...
Mitchlguzin is offline  
Old Sep 10th 2012, 11:11 PM   #10
Senior Member
 
Joined: Mar 2012
From: Dubai UAE

Posts: 466
Thanks: 11

I Ride: 1199 Panigale S Tricolore and an 848
I've just started having the same thing. I thought it had something to do with the battery going dead from the DDA. It started after I had the DDA/GPS fitted and even with a new battery is there. It's intermittent, the horn and only the right signal (atleast so far, I've not noticed anything with the left).
Delta One is offline  
Reply

  Ducati 1299 Forum > Ducati Panigale Forum > Ducati 1199

Tags
horn, issues, signal



Thread Tools
Display Modes


Similar Discussions
Thread Thread Starter Forum Replies Last Post
Turn signal problem thomaskenyon Mechanical and Technical 70 Jun 27th 2016 10:19 AM
electric problem horn and signals not working supersicsquid Ducati 1199 6 Jun 21st 2015 12:19 PM
Wiring Issues baldy Mechanical and Technical 5 Sep 14th 2012 02:54 AM
Tyre issues Kingfixer Racing 12 Sep 5th 2012 08:38 PM
Horn cable. Braintrash Mechanical and Technical 5 Jul 27th 2012 09:42 AM


Facebook Twitter Google+ RSS Feed