Go Back   Ducati 1299 Forum > Ducati Panigale Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions


Reply
 
LinkBack Thread Tools Display Modes
Old Jul 30th 2017, 07:03 AM   #1
Junior Member
 
Joined: Oct 2015
From: Seychelles

Posts: 10
Thanks: 0

I Ride: 1199 S ABS (2014) and YZF R6 (2003)
ENGINE Fault Light + No Acceleration while riding

Hi guys! 1199S 2014, under 10k kms on the clock.

Throttle cuts off and ENGINE FAULT light shows on the cluster while riding. Engine stays on but can't accelerate on the throttle. It happens quite often, seems to happen especially after wheelies.

Scary if I loose throttle in a corner

Any pointers what it could be? Oil's fine, no other issues
jrokr6 is offline  
 
Old Jul 30th 2017, 07:18 AM   #2
Senior Member
 
Joined: Sep 2013
From: New Orleans

Posts: 932
Thanks: 456

I Ride: 1199 Panigale
Mine did this. Riding and all of a sudden it dropped all throttle and went to idle. Engine didnt turn off just dropped to idle and red light came on. Scary as Fuk when you are changing lanes and passing a car and it does it. I sometimes wonder if I could vote the Panigale the scariest bike I have ridden for various dumb $hit it has done to almost kill me.

Throttle body needed replacement. They couldnt just replace the TPI, they had to replace the entire unit (Thanks Ducati)

It apparently was a problem on the 2013+ units.

NOLA
NOLA is offline  
Old Jul 30th 2017, 07:38 AM   #3
Junior Member
 
Joined: Oct 2015
From: Seychelles

Posts: 10
Thanks: 0

I Ride: 1199 S ABS (2014) and YZF R6 (2003)
Thanks Nola. dealership here closed down... it closed as soon as I bought my bike off them. will look into Throttle Body, but I'm really hoping it's something easier to fix that I can handle myself!
jrokr6 is offline  
Old Jul 30th 2017, 07:40 AM   #4
Junior Member
 
Joined: Oct 2015
From: Seychelles

Posts: 10
Thanks: 0

I Ride: 1199 S ABS (2014) and YZF R6 (2003)
''Scary as Fuk when you are changing lanes and passing a car and it does it'' happened to me a couple of times lol
jrokr6 is offline  
Old Jul 30th 2017, 07:50 AM   #5
Senior Member
 
Joined: Sep 2013
From: New Orleans

Posts: 932
Thanks: 456

I Ride: 1199 Panigale
@jrokr6

There has to be a dealer in the nearby areas you could bring it to. Something within a driving area ? Trailer it ?

NOLA
NOLA is offline  
Old Jul 30th 2017, 07:54 AM   #6
Senior Member
 
Joined: Jan 2012
From: Overland Park, KS

Posts: 667
Thanks: 96

I Ride: 2012 1199S
Originally Posted by NOLA View Post
@jrokr6

There has to be a dealer in the nearby areas you could bring it to. Something within a driving area ? Trailer it ?

NOLA
@jrokr6 location = Seychelles
kensteele is offline  
Old Jul 30th 2017, 07:56 AM   #7
Senior Member
 
Joined: Sep 2013
From: New Orleans

Posts: 932
Thanks: 456

I Ride: 1199 Panigale
I know, I read that. Assumed one of the islands has a dealer.

I looked on the dealer locator, seems the closest is Mauritius.

That sucks. You might have to do a drug deal with Ducati to get them to send you a part and install it yourself.

NOLA
NOLA is offline  
Old Jul 30th 2017, 08:26 AM   #8
Junior Member
 
Joined: Oct 2015
From: Seychelles

Posts: 10
Thanks: 0

I Ride: 1199 S ABS (2014) and YZF R6 (2003)
Yup definitely sucks!

We still have the Ducati trained mechanic though he stayed lol

I really hope it's not throttle body...

somebody told me to try this...

DISCONNECT THE BATTERY FOR 10 MINUTES.
RECONNECT THE BATTERY AND TURN THE IGNITION.
LEAVE IGNITION ON FOR 30 SECONDS.
SWITCH OFF IGNITION.
TURN IGNITION ON AGAIN AND START THE ENGINE.

This should apparently reset the ECU and might help
jrokr6 is offline  
Old Jul 30th 2017, 08:31 AM   #9
Junior Member
 
Joined: Oct 2015
From: Seychelles

Posts: 10
Thanks: 0

I Ride: 1199 S ABS (2014) and YZF R6 (2003)
BTW it happens mostly after doing wheelies... could it be possible this gives a false oil level reading and engine shuts off so you don't blow it?? Would be great if that's all it was
jrokr6 is offline  
Old Jul 30th 2017, 04:34 PM   #10
Senior Member
 
Joined: Mar 2015
From: Australia

Posts: 357
Thanks: 56

Cable and software to diagnose is cheap
Halo2 is offline  
Reply

  Ducati 1299 Forum > Ducati Panigale Forum > Mechanical and Technical

Tags
acceleration, engine, fault, light, riding



Thread Tools
Display Modes


Similar Discussions
Thread Thread Starter Forum Replies Last Post
2015 Ducati 1299 Panigale CAN LINE Internal Sensor Check Engine Light Error ABS Light ducrider Ducati 1299 11 Sep 22nd 2017 06:50 AM
Engine dies when riding.... ruley Mechanical and Technical 41 Oct 23rd 2015 11:38 AM
Check Engine Light and engine keeps shutting off JeffD Ducati 899 20 Oct 23rd 2014 06:05 AM
Engine Warning and Amber engine Light ScrapperX Mechanical and Technical 3 Apr 3rd 2013 02:31 PM
Light front under hard acceleration over 200kph WAfatboy Ducati 1199 3 Sep 24th 2012 03:08 AM


Facebook Twitter Google+ RSS Feed